Intermittent Connectivity Issues
Incident Report for IRIS CRM
Resolved
This incident has been resolved. Network health is back to normal performance.
Posted Jul 31, 2020 - 19:08 UTC
Monitoring
A fix has been deployed and system performance has returned to normal levels. We are continuing to monitor the health of the network.
Posted Jul 31, 2020 - 18:33 UTC
Identified
Client sites are experiencing loading issues. Please refresh the page if you see an error. We are actively working on a solution.
Posted Jul 31, 2020 - 17:50 UTC
This incident affected: CRM Services, Search Services, System Services, and Phone Services.