Slowness and Increased Latency While Navigating Merchant Central

Incident Report for Merchant Central

Resolved

Between 18:26 and 18:40 UTC on 14 Aug 2026, some users may have experienced slowness or intermittent errors. The issue has been resolved and all services are operating normally.
Posted Aug 14, 2026 - 16:28 EDT

Monitoring

At this time mean and p95 latency have returned to normal levels. Engineering remains highly engaged and monitoring for any recurrence of the issue.
Posted Aug 14, 2026 - 15:07 EDT

Investigating

We are currently investigating increased latency in the Merchant Central instances. We have observed increased latency in page load times and login processes. Engineering is engaged and actively reviewing the cause.
Posted Aug 14, 2026 - 14:53 EDT
This incident affected: CRM Services.